Fix for aspnet_regiis.exe -i when get "must have administrative rights"


#1

Scenario:
You install WBI, and/or MBI, and/or data portal.
You realize that the ASP.NET v4.0 application pool is NOT automatically created thereby letting you know there is an issue between your IIS and ASP.NET
You go to run the aspnet_regiis.exe -i to re-register (as outlined in the WBI, MBI and/or data portal steps of “%windir%\Microsoft.NET\Framework\version\aspnet_regiis.exe” -i at command prompt where %winver% is the Windows directory for your operating system, and version represents the version number of the .NET Framework that you installed on your server. Don’t forget to reboot after.")
BUT you get the error message
"An error has occurred: 0x8007b799
You must have administrative rights on this machine in order to run this tool. "
so you are unable to re-register. Ugh.

To resolve so you can re-register:
Turn off UAC

For example, on a Windows 7 Pro station, do the following:
Control Panel -> System and Security -> Action Center -> Change User Account Control settings (usually on the left) -> slide down to Never Notify -> OK.
You may have to reboot.
Then re-register again and confirm the ASP.NET v4.0 application pool is now automatically listed.
(undo the steps in your control panel to revert your UAC settings back to what they were)