SOLUTION If using "&" ampersand symbol when viewing via MBI


#1

We have had reports that with some web browsers that if:

  1. you log into MBI 7
  2. and the scheduled items have a client name or a workorder item status or a Schedule marker name that has the “&” ampersand symbol:
    that you will get either of the following similar errors:

(below is example of error if running FireFox)

ML Parsing Error: not well-formed
Location: http://mbi.ayanova.com/(S(gcetp5pjlovn2khhwv5c21n2))/schedule.aspx
Line Number 24, Column 346: <span class=“secthead”>All day<br/></span><span class=“sectsubhead”>2:15 PM - 4:30 PM</span><br/><a href=“ro.aspx?id=64a44c56-111e-4013-8d18-eb43002829b0&o=23”>80</a> <a href=“ro.aspx?id=93ffea54-6699-4b23-b360-69a87ca4ce6d&o=3”>Bill & Sons</a> <br/><a href=“status.aspx?id=975e4bb1-d29e-4191-ba3b-e54cd444514e”>Status & Name</a><br/><br/>
---------------------------------------------------------------------------------------------------------------

(below is example of error if running Google Chrome)

[i]This page contains the following errors:

error on line 24 at column 265: xmlParseEntityRef: no name

Below is a rendering of the page up to the first error.

| Memos | Recent… |
12/6/2012
All day
2:15 PM - 4:30 PM
80 Bill & Sons [/i]

Have also received report occuring with the web browser on a Blackberry 7.1 OS

SOLUTION:
At this time client name or a workorder item status or a Schedule marker name to not use the “&” ampersand symbol, instead use “and”


#2

This issue is not found with MBI 7.2.0.0 HotFix 3

Update to the latest AyaNova & MBI