ASP.NET permissions for WBI to work

I came across this problem while trying to get the AyaNova WBI to work. Let me preface this by saying I am a novice to and web apps. I am on Windows Server 2003 SP1 with IIS 6.0. After installing .net 2.0 and going through the WBI installation instructions, all I could get was this message in the browser: <H1 “MARGIN: auto 0in”><SPAN “FONT-SIZE: 24pt; COLOR: #ff3300; FONT-FAMILY: Verdana”>Server Application Unavailable </SPAN><?xml:namespace prefix = o ns = “urn:schemas-microsoft-com:office:office” /><o:p></o:p></H1>

<SPAN “FONT-SIZE: 12pt; FONT-FAMILY: Verdana”>The web application you are attempting to access on this web server is currently unavailable. Please hit the “Refresh” button in your web browser to retry your request. </SPAN><o:p></o:p>

<SPAN “FONT-WEIGHT: bold; FONT-SIZE: 12pt”>Administrator Note: </SPAN>An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.

<o:p>I found some documentation on setting the permissions in Windows to fix this problem. The account “Network Service” has to have “Read, Read & Execute, List Folder Contents” permissionson the root of the website and the application directory. (IE C:\Inetpub\wwwroot\ and C:\Inetpub\wwwroot\\ayanovawbi) Once the permissions were set all worked fine. Again, this is only for Windows Server 2003 and ASP.NET 2.0. Windows 2000 and ASP.NET 1.0 are different. (ASPNET local machine account versus NETWORK SERVICE local machine account)</o:p>

<o:p>Hope this saves someone the headaches I went through.:cool:</o:p>


Thank you for posting your experience here for other WBI users.

I hadn’t run across needing to provide access for the Network Service account setting up for Win2003 with WBI, but if someone else experiences this same issue, this is great that you posted this.

  • Joyce