Could not load file or assembly 'Interop


#1

Joyce,

I get the following error when I try to link to QB

“Could not load file or assembly ‘Interop.QBFC7, Version=7.0.0.134, Culture=neutral, PublicKeyToken=31d8aec643e18259’ or one of its dependencies. The system cannot find the file specified.”

Thanks,

MC


#2

Note the section of the error that says: Could not load file or assembly 'Interop.QBFC7
This error occurs because the required QuickBooks component QBFC 7.0 has not been installed as per the QBI required installation and configuration steps 1.d http://www.ayanova.com/qbi5webhelp/installationdatabaseconfiguration.htm

That step #1 identifies all requirements before installing QBI - do make sure you have all before proceeding:

Compatible QuickBooks program installed and operational on the local hard drive of your computer
Latest QuickBooks service patches applied to your QuickBooks
You have confirmed access to your QuickBooks company data file - the QuickBooks company data file can be located either on the local hard drive too, or it can be located on another networked computer
The QuickBooks component QBFC7.0 is installed (download the QBFC7_installer.exe from http://www.ayanova.com/download.htm )
The latest version of AyaNova installed and is also licensed for QBI
Do note that there are known issues with QBFC7 on 64 bit operating systems. As QBFC7 is required for QBI to be able to “talk” with QuickBooks, do not install QBFC7 and QBI on a 64bit operating system. (do note that this is a restriction of QuickBooks, not QBI)

  • Joyce

#3

Good news everyone!

Development has been working on 64bit compliance for QBI with Intuit and we plan to have this available with the 6.6.0.0 maintenance release coming out real soon!