error installing data portal

When trying to install the data portal option w/ ayanova 6.2.0.0, I get the following error:

Internal Error: Expression error 'Runtime Error (at 8:292):
Please Install Microsoft IIS first
(Error ‘Invalid class string occurred’)

Server is Windows Server 2008, IIS 7.0 is installed and seems to be working fine (can access the default page). .Net 3.5 SP1 is also installed. I also attempted to install WBI, and got the exact same error.

Ayanova is networked with firebird and working fine. I just need to get these two operational.

Hi

Haven’t experienced this error ourselves, nor has any other AyaNova user posted about it.

If you do have IIS 7 installed, it might be that IIS hasn’t been completely registered with .NET 3.5 SP1

Do the following and let me know:

  • Open a command prompt. (select Start -> Run -> type in cmd and press OK)

  • Navigate to ‘C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727’ (type in CD C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\ at the command prompt)

  • Type in aspnet_regiis.exe –i at the command prompt and press Enter (this is to register IIS and .NET again)

  • Reboot

  • Now run the WBI installation - does it now install?

  • Joyce

I ran that command, and some .net icons show up in the IIS Manager for default website, but i still get the same error when attempting to install the data portal and WBI. Also, under the default website in IIS Manager, there is no Ayanova WBI showing up as indicated should happen on the install docs.

Only odd config I have on this server is apache running on port 80 and IIS on port 8080. Any additional ideas?

Hi again

The AyaNovaWBI will not show up under IIS until it has been successfully installed - as you don’t get to that point (you say that the error message occurs when installing), than the WBI site won’t get installed until it is successful.

If you are using apache, perhaps your IIS isn’t actually fully installed with everything it needs. Or it may be that your apache is still in conflict with IIS in some other way.

A suggestion would be to disable apache on this computer, reboot, and then try the WBIinstallation again. If it installs than, you know that there was something running that was preventing the installation.

Or because apache is on this computer, disabling may not be enough because other aspects of it are still conflicting (i.e. have you assigned different ip’s to apache and IIS before installing WBI and data portal, etc), and instead you may need to set up WBI and data portal on a different computer that does not have apache on it.

Do post back what you tried of above, if resolved etc. As would be very interested to know.

  • Joyce

Hi again, was wondering what the result was of disabling apache - was WBI able to be installed than?

What about confirming each has their own ip address?

Or have you set up WBI and the data portal on another computer?

  • Joyce

I haven’t been able to disable apache as that is what our production website is on. I should be able to try this out tomorrow. I will definately keep you updated. I’m guessing that, for all intents and purposes, ayanova wbi should work fine with Server 2008 and IIS 7?

Downloading and using the Microsoft Web Platform Installer fixed this problem. Apparently something was missing from the default IIS (installed by Add Server Role), even though ASP and IIS was fully functional. Installation seems to complete now and AyaNovaDP and AyaNovaWBI6 show up under default websites now.

Thank you for posting that it was installing theMicrosoft Web Platform Installer that fixed your issue. That will help any others that may encounter a similar issue.

And glad to hear all installed successfully

  • Joyce