.NET Error?


#1

Hello,

I have installed the QBI interface, this is the error I receive:

Unhandled exception has occurred…

Could not load file or assembly ‘GZTW.AyaNova.BLL, Version=3.4.2.0, Culture=neutral, PublicKey Token=df66a8d8e49833d3’ or one of its dependencies. The located assembly’s manifest definition does not match the assembly reference. [Exceptopn from HRESULT: 0x80131040].

I believe I followed the installation instructions properly as far as re-naming the .exe file and so on.

Any assistance would be greatly apprecieted.

Joshua Bachman

Computer Works


#2

Hi Joshua

This error may be a result of running an older version of AyaNova with a newer version of QBI.

To check this - log into AyaNova, select menu Help -> About AyaNova -> what is version of AyaNova?

QBI v3.4.2.0 requires AyaNova v3.4.2.0 as stated on the QBI download web page and in the QBI Manual.

The latest version of AyaNova is 3.4.3.0 If you have an older version of AyaNova, refer to the forum section http://forum.ayanova.com/Forum96-1.aspxfor steps to update depending on what version of AyaNova you have.

Do post back here in reply if this is what the issue was.

Otherwise, do reply with what the version of AyaNova is, the path that AyaNova is installed to on this computer, the path where QBI is installed to on this computer (it MUST be the same exact path where AyaNova is installed), what version of the AyaNovaQBI.exe file is installed

  • Joyce

#3

Silly me. That was the issue. I applied the fix and it works.

Thank you again!

Joshua Bachman

Computer Works


#4

Good to hear - glad to help

  • Joyce