Potential numbering issue with SQL 2012 or higher


#1

A potential issue has been identified and a resolution found:

Issue:
a newly saved workorder numbers jump / increment by 1000 and apparently no one edited Global Settings to make it so, nor did anyone directly edit the database.

Circumstances:
SQL Express or SQL Server, 2012 or 2014 (may also occur with any newer SQL, do refer to Microsoft for more details)
A user stays logged in running AyaNova when the SQL is restarted
Then the user creates a workorder after the SQL has restarted, without that user having exited out of AyaNova since that server was restarted.

Resolution:
Microsoft has implemented a new “feature” in SQL 2012 whereby this happens.

To prevent your AyaNova workorder numbers from jumping 1000 when a new workorder is created if someone happens to stay logged in when the SQL 2012 is restarted and that someone then creates and saves a workorder without having exited out, do the following:

  1. Make sure everything and everyone is out of AyaNova program and options.
  2. Backup your database (so that in the event the workorder numbers still increment incorrectly, you can just restore from backup and redo the steps again).
  3. Open SQLServer configuration manager on your server
  4. Select SQL Server 2012 instance there right client and select Properties menu
  5. Select Startup Parameters tab from there and register -t272
  6. Restart the SQL Server 2012 instance again
  7. On one station only, log into your AyaNova
  8. Create a new workorder, save and exit.
  9. Confirm that the workorder # increments correctly

DO refer to the attached screenshots
Step3_SQLConfigurationMgr
Step4_properties
Step5a_startupparameter
Step5b_startupparameter
Step6_restart