QBI NOW compatible with 64-bit operating systems


#1

.

PLEASE NOTE: QBI 6.6 and higher is NOW compatible with 64 bit operating systems!!

Please note thatQBI can not be run on a 64bit operating system due to limitations with the QBFC component from Intuit.

If you do install QBFC and QBI on a 64bit operating system, you will get the following message when you try to run QBI

Retrieving the COM class factory for component with CLSID {FC3C4882-C13E-46E7-96F1-CEE3133207B7} failed due to the following error: 80040154


Do note that if you get the above error running QBI on a 32bit operating system (Windows 2000, XP, Vista, etc) it may be because of either of the following:

  • You have not downloaded and installed the QBFC required before installing QBI as per the QBI Help file on installing QBI
  • Or you have installed QBFC, but have not rebooted your computer
  • Or you have installed QBFC, and have rebooted your computer, but the QBFC dll did not get registered correctly. If that is the case, from Run type in the following to register (example command belowis for QBI 5):

regsvr32 “C:\Program Files\Common Files\Intuit\QuickBooks\qbfc7.dll”


#2

Is there a workaround. I am running 4.2, will upgrading to 6.0 resolve the 64 bit issue or do I wait for Quickbooks to make a fix?


#3

Hi Larry

We are too also waiting for Intuit to fix this - so unfortunately no, there isno workaround at this time, other then not to use a 64 bit operating system.

You can only use a 32 bit operating system to be able to use the optional add-on QBI because of this limitation of Intuit’s.

  • Joyce

#4

Great news everyone!

QBI 6.6 and higher is now compatible with 64bit operating systems!

Update to the latest version!


#5

Hello Elizabeth

I believe there is a misunderstanding, AyaNova QBI 6.6 and higher IS compatible with a 64bit computer.

If you are experiencing an issue, do provide the following so we can help:
[ul]
[li] What your operating system is on this computer
[/li][li] What your bit is - 32 or 64
[/li][li] What QuickBooks country, version and year installed on this same computer? (i.e. US QuickBooks Premier 2011)
[/li][li] Confirm that your QuickBooks has the latest Updates
[/li][li] Confirm have downloaded and installed QBFC7 as per http://www.ayanova.com/qbi7webHelp/installationdatabaseconfiguration.htm
[/li][li] Have you networked AyaNova? Using what configuration?
[/li][li] And if networked AyaNova, is this computer you have QuickBooks and QBI on, also the server?
[/li][/ul]

  • Joyce