API download


I have downloaded the AyanovaAPI.zip file. I have tried to extract it to my computer, but I get errors. It’s the same errorfor each document: 0x80004005.

Do you have any idea what might cause this?

Hi Bianca, I just downloaded it and extracted it with Winzip to confirm it’s ok and it seems fine. Are you using Winzip or some other zip utility? It’s alsopossible it got corrupted when you downloaded it, please try it again. If you still have problems post back and let me know which zip utility you were using and the results of re-downloading it.

I used WinRar, tried it on two different computers with no luck. So I tried Winzip, and finally succeeded :slight_smile:

Cool glad to hear you got it. And thanks for letting me know about the issue with WinRar, I’ll look into it.


FYI, I just had the same issue with WinRAR. I’ve used it for years and it handles everything, this is the first ZIP I’ve seen that didn’t work but was actually OK (as proven by working OK with WinZIP).

I would suggest you re-zip it with WinRAR as a ZIP or the XP built-in compression tool to guarantee maximum compatibility. Never seem to have a problem with stuff zipped with WinRAR. :slight_smile:

I thought I had that problem licked, sorry.

I think I’ll just make it a self extracting executable. :slight_smile: Weird, we’ve been using Winzip for years with no problems and just yesterday one of our component suppliers had a zip archive update and I couldn’t open it with Winzip but could open it with 7zip.

Ok, problem solved, I used 7Zip to make a self extracting archive which including the self extractor inside it is still less than half the size of the winzip archive. I think it’s time to ditch Winzip. Thank you all for your patience.