Can't receive purchase order

I am trying to receive a purchase order that has a status of ‘Open - on order’. When I go to ‘Purchase order receipts’ and select ‘new’, I select the vendor from the list. From the pop up, I select the purchase order, check the ‘select’ box, and hit ok. Another pop up appears, but the ‘Purchase order receipt item’ box is grayed out, and there are no options to receive anything. If I save it as is, it doesn’t close the purchase order.

The workorder has 3 part requests, and only 1 has been received. How do I fix this, as I can’t find a way out of this to close the workorder. Thanks.

Hi Barney

Go to the Purchase Order grid, open the Purchase Order # you had checkmarked in the Select Purchase Orders to receive… window. Confirm there are parts selected in this PO and that each part has a quantity identified too.
Make a screenshot of this Purchase Order entry screen and attach to your reply
Now go to the Purchase Order Receipt grid
Select New… and select that vendor of that PO
It will list all open Purchase Orders for that specific vendor. Place a checkmark on the row for that specific PO . Make a screenshot and attach to your reply
Click on OK and the Purchase Order Receipt entry screen displays with al parts ordered so that you can edit.
Make a screenshot of this Purchase Order Receipt entry screen and attach to your reply
For your other question “The workorder has 3 part requests, and only 1 has been received. How do I fix this, as I can’t find a way out of this to close the workorder” - if a workorder has part requests that have not yet been ordered or received, but you want to close the workorder, just delete the part requests in the service workorder itself -> open the service workorder, view the Parts subsection, select the row header for the part request which highlights it, hit the Delete key on your keyboard, accept the deletion, now save the workorder. Now you can close the service workorder.

  • Joyce

I still cannot delete parts or part request. Please see attachments.

Hi again and thank you for sending the screenshots.
First note that the part TEP12 that is a part request in Workorder #41 is not that ordered in PO #34. That part request for the part TEP12 is on order via the PO #36.

You can see this also via the Part Requests grid in the Inventory navigation pane. You will see that the part TEP12 that is listed there as a part request that is tied to workorder #41 is actually on order via PO# 36.

And the reason why you can not delete the part request via the service workorder #41 entry screen is because that specific part request is still on order in PO #36 and has not been received, but the screenshots you have sent are about PO#34 which is a different purchase order. You can not delete a part request if it is on order - only if it is not yet ordered, or has been received.

View the Purchase Order #36 - see how in that PO items subgrid, the Workorder # field is actually showing workorder #41? This is the PO that must be received and closed, or Closed via the PO menu option before you can delete that part request from the workorder #41.

Also note in AyaNova, if you attempt to delete a part request that is on order and not yet received, you will receive an actual message “A workorder item part request can not be deleted when parts are on order. Once parts are received it may be deleted.” but your screenshots are showing the error “violation of FORIEGN KEY contraint “FK_APURCHASEORDERITEM_AWORKORDE” on table “APURCHASEORDERITEM””. as if there is some internal issue or problem. Please confirm that you are using AyaNova by selecting Help -> About AyaNova.

Do the following and let me know:

Make sure you do not have the workorder #41 entry screen open.
Make a Purchase Order Receipt for vendor Ingrim, and receive for Purchase Order #36 and save
Open the workorder entry screen for workorder #41
Select the row header for the part request for TEP12 and than press the Delete key on your keyboard. Save the workorder.
Were you able to delete the TEP12 part request within wo#41?
Now one of those SPT355 part requests was there when the sample database was installed, and the other would have been added by yourself. From the screenshot you sent, neither of those have an Ordered Date, so neither of those are on order and should be able to be deleted.
Select the topmost SPT355 part request via its row header and press the Delete key on your keyboard - does it allow you to delete it?
And do the same for the second part request for SPT355 - does it allow you to delete?

  • Joyce

Also if you could zip up your AyaNova database file using WinZip and attach it to an email directly to referencing this forum topic (I am assuming here that you have installed the trial AyaNova for default stand-alone use - if so, just exit out of AyaNova and than zip up the AYANOVA.FDB database file). This way I can also take a look at it and see directly what is happening.

  • Joyce

Joyce, after sending you the database to try, you responded that it was working fine. I tried it again and it worked ok for me. Must have been my bad.

I figured out why I couldn’t delete. It was a permissions issue. The first time I tried it, I must have been logged in as a technician, whereas when I tried it later, I was an administrator and I could. I think the problem is that there is no warning that you don’t have permissions when you try to delete it as a technician.

Hello again Bleu

Could you confirm the exact sequence of events so that I can recreate getting that error message you received when attempting to delete a part request in a workorder when logged in as a user that does not have Delete rights to Object.WorkorderItemPart. For example, if I do the following, there is no error message as you show in your screenshot you initally sent:

I logged in as Hank (who is a user of Security Group Technicians that has Read/Write only rights to Object.WorkorderItemPart)
I viewed workorder #41 and its Parts subsection
I select the row header for the Part Request for the first SPT355 to highlight it
I press my Delete key on my keyboard.
Nothing occurs - no error and no deletion - because I am a user that does not have Delete rights.

  • Joyce

That is correct.