Changing workorder status and closing using WBI

When using the 3.4.0 version of WBI and Ayanova 3.4.0 we are unable to see or select any of the workorder status options in the pulldown. Additionally, the option to change the workorder to “closed” is greyed-out and unable to be selected. These options work correctly when using the direct interface (instead of the WBI). Screenshot will be provided separately via email.


When you select a drop down list via WBI that is in an entry screen, click on the “more” area at the bottom which results in WBI requesting the list of items from the database as per the screenshot below - this can also be found in the WBI 3.x Online Manual section Selecting via a Drop Down Box

This feature is so that when you load a workorder, it happens right away without getting all the lists of every possible drop down selection on a workorder - only gets it whenyou actually want it.

If the Closed button is grayed out, that would indicate that the user who is logged in via WBI does not have the security group rights to checkmark the Closed box - the Object.Workorder.Close must be set to Read/Write/Delete for the security group that the user belongs to.

-Log into AyaNova as the AyaNova Administrator (or a user with full rights to everything)
-Open the Administration navigation pane
-Open the Users grid
-Find the user that was logged in via WBI and find out what their security group is
-Now open the Security Groups grid and open that security group
-Find the Object.Workorder.Close right, and ensure it is set to Read/Write/Delete if you want all users of this security group to have the ability to set a workorder to Closed and therefore close this workorder so that it can not be edited any further by anyone.
-Save the security group
-Now have the user log into WBI again and open the workorder - the Closed checkbox will no longer be grayed out

  • Joyce

Thanks Joyce - I had just determined the “Closed” status was a rights issue and addressed it. I didn’t expect the pulldowns to need a “refresh” to be able to view the options. Problem solved!