Data Portal running slow on remote site

When I use the original config.txt file which points to the correct server and database, AyaNova runs really slow. To start up after logging in takes about two minutes and just opening a workorder takes about 1.5 minutes. This was not a problem before upgrading from 3.6 to 4.1. When on a computer which is on the same local network as the server everything runs normally.

<?xml version=“1.0” encoding=“utf-8”?>


I tried to use the EXAMPLE_DATAPORTALconfig.txt file with the appropriate server address and port number and got the following. I get this same message whether I am on the server, local computer, or remote computer. I have created a port in the router firewall. I get the correct results when I enter on the server as well as the remote machines.

Error message:

AyaNova was unable to start

Depending on how early in startup the problem occurred,
a detailed log of the problem with suggestions may have
been saved to the file AyaLog.txt
located at: file:\C:\Program Files\Ground Zero Tech-Works Inc\AyaNova_CC

Error details:
Unhandled exception:
The input stream is not a valid binary format. The starting contents (in bytes) are: 3C-68-74-6D-6C-3E-0D-0A-20-20-20-20-3C-68-65-61-64 …

Stack Trace:

Server stack trace:
at System.Runtime.Serialization.Formatters.Binary.SerializationHeaderRecord.Read(__BinaryParser input)
at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.ReadSerializationHeaderRecord()
at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.Run()
at System.Runtime.Serialization.Formatters.Binary.ObjectReader.Deserialize(HeaderHandler handler, __BinaryParser serParser, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)
at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Deserialize(Stream serializationStream, HeaderHandler handler, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)
at System.Runtime.Remoting.Channels.CoreChannel.DeserializeBinaryResponseMessage(Stream inputStream, IMethodCallMessage reqMsg, Boolean bStrictBinding)
at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at CSLA.Server.DataPortal.Fetch(Object Criteria, DataPortalContext context)
at CSLA.DataPortal.Fetch(Object Criteria)
at CSLA.Security.BusinessIdentity.LoadIdentity(String UserName, String Password, AyaNovaConnectionSettings ACS)
at CSLA.Security.BusinessPrincipal…ctor(String Username, String Password, AyaNovaConnectionSettings ACS)
at CSLA.Security.BusinessPrincipal.Login(String Username, String Password, AyaNovaConnectionSettings AyaNovaConnectionSetting)
at GZTW.AyaNova.BLL.AyaBizUtils.1()
at GZTW.AyaNova.BLL.AyaBizUtils.Initialize()
at AyaNova.Form1.0()

Hi again

I am not sure if I understand this right - you are trying to have a remote computer connect to the database using a local area connection and are saying it is too slow?

As per the Data Portal installation and configuration steps, you do NOT have a remote computer connect using the same connection as a local area network computer - it of course would be massively slow.

If you connected remotely from a computer runinng AyaNova 3.6 directly using the local area network configuration, it would also have been slow because you also would only connect from a remote computer using the Data Portal configuration.

The Data Portal is specifically created to to be in between a remote computer and the database server. And the AyaNova 4 Data Portal and AyaNova 4 itself has also been optimized for increased speed.

I believe there is a misunderstanding here of what is to be done.

To your other issue you posted about:

When I try the connection get a completely different message than what you list in your posting.

The link what you would enter to test remotely step #13 of the Data Portal connection steps, but does this mean you have successfully completed the steps prior to this?

From this link, I am assuming that you have set up a new virtual Data Portal site rather than using the default installation of AyaNova 4’s Data Portal (otherwise it would be http://ipaddress:portnumber/AyaNovaDP/dataportal.rem?wsdl):

When you initially test as per step #13 of the Data Portal connection steps (URL removed as for older version no longer supported - see the latest version of AyaNova) , on the server itself where the Data Portal is installed, you enter to confirm that you have the basics installed correctly - where is the private internal ip of the server, and XXXX is the port number as per the previous steps.

**Confirm what exactly you enter at the server itself for step #13

**Confirm do you actually receive what it shows in the screenshot for that test?

**If you do not successfully get as per the screenshot for that step,that means that you have something installed incorrectly or not confirmed or setand need to redo your previous steps.

If you do not successfully perform a step, you of course are going to get even more issues if you gopast that step and ignore it. You must address an installation and configurationissue when it comes up before continuing.

**It may be a similar issue that you had with your WBI that you had just recently posted about - that there was something major wrong with the installation itself such as files missing, and re-installing fixed it. I would recommend that you redo your steps from the beginning, and note them down as you go, so that if you encounter an issue again and have confirmed you have done and checked each step, you can provide that information so that we can troubleshoot.

  • Joyce

Hi again

Do post back - did you recheck your Data Portal setup steps? Or installed again from scratch to be sure that you did not miss a step?

Do post back and let us know that it has been resolved

And if not, do provide details on each step so that I can help specifically as may see something that is the cause.

  • Joyce

Just wanted to post here for any others that encounter a similar error message as we did not hear back from the original poster of this issue.

An organization using AyaNova just experienced the error message The input stream is not a valid binary format. The starting contents (in bytes) are: 53-65-72-76-65-72-20-65-6E-63-6F-75-6E-74-65-72-65 on two computers this morning after applying windows updates to all.

In their case, these two computers were connecting via a data portal connection, and the server itself where the data portal was running possiblyhad corrupted .NET Framework after the windows updates.
Resolved by reregistering .NET with IIS, reboot, and then reinstalled DP, perform DP tests to confirm all good, and error resolved

We have also able to reproduce the same error message if an incorrect port number is used with a data portal connection - i.e. the ip address is correct, but the port number is not such as the database connection string in their config.txt is and the ip address is correct but the port 3434 is not.

If you encounter a similar error message, do check as per the suggestions above.