De-serialization Error! on one client computer after upgrading to v3.5.0

After upgrade to v3.5.0 I receive this error after entering login credentials

This error is occuring on my laptop, and is the same whether I run the trial against the local firebird db, or as a licensed user against my SQL Server instance.

I’ve attached a copy of the error and of the Ayanova log file. Any suggestions appreciated. :ermm:


Hi Dan

Sorry, but I haven’t encountered such an error before to be able to give you a specific fix.

What I would recommend as the error identifies in the ayalog.txt that the AyaNova program can not find a file, but unfortunately doesn’t identify the specific file it requires, is to do the following:

-delete all the AyaNova program files on the notebook
-copy all of the AyaNova program files from a computer that is running AyaNova v3.5.0.0 correctly to the notebook
-Now run AyaNova again on the notebook.

Let me know the result

  • Joyce

Hi again Dan

Do post back about this - let us know if replacing the files fixed the issue or not.

  • Joyce

Thanks for the reply Joyce!

I tried remove/reinstall several times, but in the end found a repair install on the .NET Framework 2.0 solved the problem. :slight_smile:


Thank you Dan for posting what resolved the problem in the event it occurs for other users.

To re-iterate, the issue was that the following error occurred:

De-serialization Error! —> System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

And the fix was to perform the .NET repair - two ways of performing the repair:

One way:
-Open Control Panel -> Add/Remove Programs
-Select Microsoft.NET Framework 2 and select Change/Remove Select Repair
-This will take at least 5 or more minutes
-When finished, you must reboot the computer

Another way:
-Click Start, and then click Run.
-In the Open text box, type cmd, and then press ENTER.
-At the command prompt, type the following, and then press ENTER:
"%windir%\Microsoft.NET\Framework[i]version[/i]\aspnet_regiis.exe" -i

In this path, %winver% is the Windows directory for your operating system, and version represents the version number of the .NET Framework that you installed on your server. You must replace this placeholder with the actual version number when you type the command.

Refer to the Microsoft topics additional information on using aspnet_regiis.exe