Email notifications for Clients

I ahve configured the email settings etc as documented i.e. Event Generator service is running, Region is configured and enabled, client has a valid email and is int he region that is configured etc but - No emails are being sent? The only thing I can think of is: Does the SMTP login information have to be filled in? i.e. Our SMTP provider does not require a login to send email so I have the login and password blank. Also, the server account, does it have to have an email client configured for SMTP emails to be sent?


Yes, SMTP information does have to be filled in. A login and a password are required.

And if editing Global Settings SMTP,don’t forget to restart the Generator. Alsocheck your Notification Logs in your Administration navigation pane also as will help identify the issue.

Do reviewother posts in this forum section such as

Also it is recommended to perform step #12 of the Generator steps as this confirms that your Generator is set up correctly and eliminate it in your troubleshooting steps. Then perform the steps again, but this time with a delivery method of email with a valid email address to confirm this easy notification works before testing with client notification.

If repeat of step #12 but with delivery method of external email does not work, than you know there is some setting wrong with SMTP like incorrect information or missing information in one of the SMTP fields of Global Settings.

  • Joyce

My Notification delivery field has an error: SMTP Delivery error: One or more required fields empty, undeliverable. Under global settings the only empty field is the SMTP Encryption. BUT - Again, our host does not require SMTP login so could that be the issue? I just entered my POP email account and password information.

I did check everything with the event generator and it is running as expected with the necessary events in the application log.

I found that error - It was because my internal delivery methos for email had no email field entered. Now if I send a memo, I get a successful delivered messages in the notification deliveries - But no Internet email.

I keep going back to my original comment - When I change any of my email accounts to use an SMTP login and password - I get an error:

Task ‘Server Monitoring - Sending’ reported error (0x800CCC80) : ‘None of the authentication methods supported by this client are supported by your server.’

With those fields blank, it all works perfectly but in Ayanova, you cannot leave those fields blank?

Hi again PG

AyaNova’s Global Settings requires a valid login and password in the SMTP fields where indicated. No they can not be blank as per my previous reply.
I would recommend doing searches online (i.e. via Google) for the error message you receive “Server Monitoring - Sending’ reported error (0x800CCC80) : 'None of the authentication methods supported by this client are supported by your server” to see if others that have encounterered and what they have checked and troubleshooted in relation to this error as may give you ideas on what to check and try. I do not have any specific suggestions for such an error.
I would also suggest setting up SMTP settings in AyaNova using gmail’s SMTP to confirm.
[li]SMTP ecryption = SSL[/li][li]SMTP Login = your gmail account[/li][li]SMTP password = your gmail account password[/li][li]SMTP Reply To = your reply to email address for emails that are sent out[/li][li]SMTP server =[/li][li]Use Notification = True[/li][/ul]- Joyce

I do not need to search for the error as I know what it means. You have to remember that here in North America, there are virtually no email providers that require SMTP authentication. In my case, I use Shaw as my cable provider so I am on their network - My email is hosted by Shaw etc so no SMTP authentication is required. In fact, if you use SMTP authentication, you get the error that I listed.

Having Ayanova force you to use SMTP authentication rules out a very, very large portion of the population from using an excellent feature of Ayanova. Is there no way to change it so that SMTP is NOT required?

Hello again PG, I am sorry if there has been a misunderstanding, but SMTP Authentication is NOT a required field.

If you view the Help section for Global Settings, it says SMTP Encryption - Encryption method to use with SMTP server. Valid values are TLS, SSL or empty for no encryption

The login name and password are required.

  • Joyce

It is not the just the SMTP authentication field but the user and password which are not required either. Regardless, I set up a gmail account and it does not work either. I have exited, restarted the generator service etc but still not emails. Is this feature compatible with Windows 7 Professional? Also, no firewall is blocking either - Surely I cannot be the only one who has issues with this feature?

Hello again PG, thank you for testing with the gmail SMTP. If you also are experiencing an issue with the gmail SMTP settings, there is defintiely something specific to your setup that is havig a problem. I would suggest rechecking again -confirm no firewall blocking by turning it off completely to test (and reboot of course), double-check the SMTP entries in Global Settings that no spelling mistakes, etc; set up the generator on a different computer. And yes, the SMTP settings are compatible with Windows 7.

  • Joyce

I have found the problem - Even though the firewall was turned off in the AVG interface, the service was still running. When I stopped the service as well, the emails went out. Do you happen to know what service or program I have to add to the firewall exceptions for this to work - I tried the ayanova.exe but that made no difference.

Good to hear you determined that the issue was related to the firewall.

What the exception should be put on depends on what your firewall is seeing as needing it.

View your logs to see what it identifies that it has been blocking - i.e. it could be the Generator.exe, it could be a specific DLL such as the ChilkatDotNet2.dll or GZTW. AyaNova.BLL.dll etc

  • Joyce

In this instance, it was the Generator.exe that needed to have a firewall exception.

  • Joyce

I have similar problems to this post, although I get a different error in the Notification deliveries which I can’t seem to copy to this message. It begins with:" T2.0 Need new SMTP connection…SMTP_Connect:Connecting to SMTP server…Cannot get host by name…hostname: Failed to connect to SMTP server

I tried the gMail server with similar results.

However, there is no firewall running on this server, and although we do have an agency firewall. But, the agency firewall isn’t blocking any deliveries to this SMTP server. My HP plotter uses this SMTP server to send us mantainenance messages all the time. Also, the generator service is actively delivering Ayanova events to several people, and has been for years. Any other ideas?

Thank you.


Hi Frank

What do you mean exactly by “the generator service is actively delivering Ayanova events to several people, and has been for years”?

Are you saying that AS OF RIGHT NOW you DO have user’s that have subscribed to notification events with an Physical Delivery Method of Internet Mail Account and these users DO get email notifications successfully?
BUT then what exact notification and to whom is getting this error? Please provide details of what the issue specifically is

And also provide confirmation of each step of
And if any issues, provide further details of Generator installation steps, your Global Settings SMTP Settings, details of what has been set in the user’s notification subscription and delivery method, and details of what all set in the client’s entry screen and Regions for client notification.
As you have seen by previous posts, it is possible to accidently overlook one or more required steps, so it is ALWAYS recommended to recheck your steps throughly if you are experiencing an issue.
If concerned about privacy of your details, you can certainly send full details via direct email to rather than posting here

  • Joyce

Clarification…Re: the generator service. I (personally) have subscribed to a notification to get a pop-up when a new Customer Service Request is received by AyaNova. It has always worked. Also, a log item is being created for the test e-mail events I’ve constructed, so I can only assume that the generator is working correctly. It appears to be a connection issue to me, but as I said, there is no firewall running on that server which seemed to be the fix in this thread. I went through the steps carefully on the help link you sent, and if I missed something, it wasn’t obvious.

Actually, the Notification deliveries log has an SMTP connection error entry every five minutes where it’s trying to connect to the SMTP server.

I also tried using the IP address of the SMTP server, and that did not work.

It could very well be an issue with our agency firewall, but as I said, the HP Plotter we have uses the same SMTP server to send maintenance alerts, and it works flawlessly. I’ll check with the network folks, though, to see what they might know.

Just looking for answers.


I was able to make it work successfully using an IP address for the SMTP server. I must not have save/exited/restarted correctly the other time I tried it.


Excellent to hear Frank, and thank you for posting what resolved so that can help others too!

  • Joyce