Import Utilities - Error in ImportPartCSV version 3.4

I followed the manual as to install the import/export utilities.

When i open ImportPartCSV.exe I get an error as follows:

Part importer v
unhandled exception.
item has already been added. key in dictionary ‘Toshiba’ Key being added ‘Toshiba’

The details are as below

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: Item has already been added. Key in dictionary: ‘Toshiba’ Key being added: ‘Toshiba’
at System.Collections.Hashtable.Insert(Object key, Object nvalue, Boolean add)
at System.Collections.Hashtable.Add(Object key, Object value)
at ImportPartCSV.Form1.Form1_Load(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativewindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativewindow.WndProc(Message& m)
at System.Windows.Forms.Nativewindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files/Ground%20Zero%20Tech-Works%20Inc/AyaNova%203/ImportPartCSV.exe

Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System.Windows.Forms/

Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System/

Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System.Drawing/

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files/Ground%20Zero%20Tech-Works%20Inc/AyaNova%203/GZTW.AyaNova.BLL.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files/Ground%20Zero%20Tech-Works%20Inc/AyaNova%203/CSLA.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files/Ground%20Zero%20Tech-Works%20Inc/AyaNova%203/CSLA.Core.Bindablebase.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files/Ground%20Zero%20Tech-Works%20Inc/AyaNova%203/CSLA.Server.DataPortal.DLL

Could you please contact Me as we need this resolved by the end of next week.

Thanks a bunch



I will point you towards the search result of searching for Key dictionary which results in the AyaNova Support Forum topic Solution-for-error-message-running-the-ImportPartCSV-utility

For your convenience, I encourage you to use the search feature of this forum to find a solution to an issue you may be experiencing.

  • Joyce

Hi Joyce

Thanks a bunch was scratching my head for days.

I can now see the error of my ways

Thanks again

Hello, again

I have another issue with Import utility,

We are running AYANOVA out of another office, we are using Ultra VNC, to remote into the PC.

We are using a Firebird server, configured correctly, AYANOVA runs fine off the Firebird server.

the Firebird server is running on a windows XP Pro Machine, with AYANOVA installed on the same pc.

When i start the import utility i get a, invalid connection string.

I have made sure i can access the Gsec shell, and that the importcsv.exe.config file is a copy of AYANOVA.exe.config, But only get the error in the Import utility.

I have gone through the manual and tried any possible solution, even the config files.

I have the latest Import Utility (downloaded it yesterday), but still get the same issue.

Could you please offer any advice


Are you running the Import utility on a computer within the same network at the AyaNova database?

  • Joyce

Yes I am running Both the Database and Ayanove from the Same XP Pro pc

Hi again

But is the Import utility itself being run on a computer within this same network - or are you connecting remotely from a remote computer that has the Import Utility installed on it?

  • Joyce

AyaNova Sales & Support (4/4/2007)Hi again

But is the Import utility itself being run on a computer within this same network - or are you connecting remotely from a remote computer that has the Import Utility installed on it?

  • Joyce

I am running everything from the same PC, in a network configuration

Hi again

  1. Zip up a copy of the AyaNova.exe.config file and the Import’s configuration file into a WinZipfile and attach.

  2. log into AyaNova, select menu Help -> About AyaNova -> provide the full version. Exit out of AyaNova

  3. Provide the full text of the entire error message you receive when running the Import utility

  4. Open Windows Explorer and move to the AyaNova program folder on this same computer (default is C:\Program Files\Ground Zero Tech-Works Inc\AyaNova 3) and provide the file date and version number of the import exectuable file (i.e if you are getting this message with ImportPartCSV, that provide the file data and version number of the ImportPartCSV.exe file)

  • Joyce

I’ve been staring at my computer to long, i have found the problem, i was using the online manual to get the file name right for the Importpartcsv.exe.config, only to realize that there was a typo in the online manual,


So now it works.

If you could please amend the online manual so others don’t fall into this trap

Thanks again,

Hi Ricko

Thank you for providing the information on what solved it, and I stared at the OnLine Manual link for a while at to figure out what you meant by a typo - and clued in because it refers to ImportClientCSV when it should have referred to ImportPartCSV. my bad.

I will definitely have this updated on the OnLine Manual asap. Thank you for bringing it to my attention so I could fix it.

  • Joyce