Inner exception: Timeout expired. Help!

Ayanova 3.5 with SQL Express. Came in to work today and had all the client computers displaying this error. I can boot the server and run Ayanova fine there. I’ve disabled all firewalls, rebooted all the computers and I still get nothing.

AyaNova was unable to start

Depending on how early in startup the problem occurred,
a detailed log of the problem with suggestions may have
been saved to the file AyaLog.txt
located at: file:\C:\Program Files\Ground Zero Tech-Works Inc\AyaNova 3

Error details:
Unhandled Exception:
Exception has been thrown by the target of an invocation.
Inner exception: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

Stack Trace:
at System.RuntimeMethodHandle._InvokeMethodFast(Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)
at System.RuntimeMethodHandle.InvokeMethodFast(Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at CSLA.Server.DataPortal.CallMethod(Object obj, String method, Object[] params)
at CSLA.Server.DataPortal.Fetch(Object Criteria, DataPortalContext context)
at CSLA.DataPortal.Fetch(Object Criteria)
at CSLA.Security.BusinessIdentity.LoadIdentity(String UserName, String Password)
at CSLA.Security.BusinessPrincipal…ctor(String Username, String Password)
at CSLA.Security.BusinessPrincipal.Login(String Username, String Password)
at GZTW.AyaNova.BLL.AyaBizUtils.0()
at GZTW.AyaNova.BLL.AyaBizUtils.Initialize()
at AyaNova.Form1.0()


If you have reconfirmed that the firewall is not on, timeout errors could be caused because the database needs to be re-organized and re-indexed.

I would suggest reviewing the topic performing a database optimization.

Also check that your SQL backup is set to Simple Recovery as outlined in check the size of your log file. If not, make sure the backup is Simple Recovery, run a backup, check the size of the log file again, and than have the networked computers log into AyaNova.

Do post back your result. Also identify if using SQL Express 2005 or if using a full SQL Server 2000, etc.

  • Joyce

Turns out… DUH… Windows Firewall was on and a port was being blocked. Not sure why that would change now, but it did.

Thanks for the help!

I have AyaNova SQL Express and I’m getting this error, I confirm that the Firewall is off and the log file is not 20% larger than my database. I can log in with all the operators users but when the Administrators log in I get the message. What else can I do?

I appreciate all the help.

Please confirm - you are getting the message “Inner exception: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.” ?

And you get this message when logging into the AyaNova program as the AyaNova Administrator?
But you do not get this error when logging in as certain other users?
Please identify login names (so that I refer to the exact in my reply) and the security groups the user is a member of, and which is the AyaNova Administrator account and whether that AyaNova user can successfully log into AyaNova or instead gets the specific error.
And it doesn’t matter what computer you test logging in as these AyaNova users this from - the exact same error occurs?
And you have also tested logging into AyaNova as the AyaNova Administrator at the server itself and you get this exact same error?
Please zip up a copy of your ayalog.txt file and attach as well as confirm the above

  • Joyce

Hello Joyce,

  1. I’m sending you the error we are getting.

2 & 3. Yes, I’m getting the message with all Administrators user but operators and Schedule users

  1. The users are manager (AyaNova) ELopez, with RLopez I can log in but as soon I click on anything I get the error.

5 & 6. I tested on the Server and 3 workstations.

Thank you Joyce, I will be waiting for your response.

Viviana Wever

Hi Viviana

Thank you for sending the information and files. In the ayalog.txt I can see that before this timeout error, you were also getting the error:

A transport-level error has occurred when sending the request to the server. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.)

That error indicates that the connection was closed for some reason. Because you are also now getting timeout errors, that indicates you might have something not set up on the SQL Express or something else funky with it

Timeout errors can be hard to narrow down -first, reboot the server (after getting everyone out of AyaNova of course), and than at the server itself first, log into AyaNova and see if the error occurs. Than from a workstation and so on. What you are trying to do here is see where it first starts from and when etc
If the error reoccurs, check your SQL error logs and Event Viewer to see what other information is showing up on the server when the timeout errors occur that may help in troubleshooting and pointing you towards what is the matter with your SQL Express.
Go to and double-check everything stated on that useful site is definitely set up - TCPIP protocol is using the Surface Configuration, TCPIP is enabled, SQL Server Browser is running, you have rebooted the server

  • Joyce

Hi again, do post back here what you found in your troubleshooting, and confirmation that your settings are done. Other AyaNova users here on the forum as well as us may also be able to provide suggestions based on the information you find such as errors messages in SQL and Event Viewer

  • Joyce