Parameter is not valid

I’m not sure that this is the proper formum topic to post this to, but in lieu of a better choice…

Myself and at least one other user got an error “Parameter is not valid.” when we logged into AyaNova 7 (Windows client) this morning. I’ve checked the Events log, and don’t see anything pertaining to AyaNova, and I also checked the AyaNova 7 Support Forum. When I receive the error, there are options to Abort, Ignore, Copy All, and by clicking the Ignore option, AyaNova starts and appears to function normally.

Your assistance is appreciated.



Good morning Frank

Thank you for contacting us that you received an error. Please provide more information to be able so that we can together troubleshoot such as:

Reconfirm - is this the full text of the error? - this is very important that ALL of the text be received to help troubleshoot. I've not seen an error where only the text ""Parameter is not valid."" shows, which is why I asked so hoping to get more details so we can figure this out together.
What exactly happened step by step for each of you to getting this message: for example, was both of your computers powered down, them powered on? logged into the computer workgroup or is it a doman?, what other programs were running before running AyaNova? At exactly what point did the error occur - before the AyaNova login screen showed, after you logged in and before anything of the user interface showed, or after you logged in and in the background could see XXX grid come up and the error message "" showed? Did you both log in as the same AyaNova user or ? What grid came up for both of you? Was the grid filtered - explain what was showing on the grid, xx records of xx, filtered, etc
Did anyone else in your company perform the same steps as
Are you able to recreate getting this error redoing the same steps?
Attach copy of ayalog.txt file from both computers that received the error message (suggestion is to make copy of each, rename with user's name so I know which is which i.e. Frankayalog.txt)

Not realizing I could attach files to this post, I also e-mailed a screen capture of the issue. This error occurred directly after a re-boot of the PC, and with NO other programs running. And, yes, I can recreate it every time I start AyaNova 7. My local copy of Ayalog.txt exceeds the limit allowed by the forum upload, so I’ll send it via e-mail However, it shows a FATAL exception the last few times I’ve started AyaNova.


Hi Frank

This may indicate an issue with specific data in one or more of the fields in the grid that displays on loading, that we have not encountered before.

Do include troubleshooting results as well as the details requested such as:

is this the exact same grid that the other employee opened to when get the exact same error, same filter, etc?
does the error occur if the first grid on open is a different grid?
does the error occur if the user logged in is someone else, and which grid does it open to, and is there a filter?
what need to do is identify in what [b]specific circumstances[/b] does it occur, and what circumstances does it not occur.

I have also replied to the email message you directly sent to.

  • Joyce

I don’t have accurate details from the other employee. She’s located in an office 900 miles from here, however, when I asked her to restart Ayanova, she said she didn’t get the error again. None of two other Ayanova users in MY office have received the error. It does occur on other grids. One of the first things I tried was changing to the schedule grid, shutting Ayanova down, and re-starting. I got the error. In regard to the circumstances which cause it to occur…it doesn’t ever NOT occur. In other words, each and every time I start Ayanova, I get the error. I just checked and I have Ayanova (Hotfix 7).

So to confirm:

  • only when you log in as yourself do you get the error
  • the error message occurs only for you no matter what grid is the first grid that loads (i.e. before exiting out of AyaNova, you view Schedule screen, then exit out. then run AyaNova and log in and the same error occurs even though the first screen on load up is the Schedule screen)
  • other users performing the exact same steps (what screen or grid on load up, etc) do not get the error

When did this first happen for you?
What changed between when it last did not happen for you, and when first happened?

Do the following and let me know:
Exit out of AyaNova
Run AyaNova to bring up the login screen
Enter your username and password
Before clicking on the OK to login, hold down the SHIFT key on your keyboard and continue to hold down afer clicking on the OK button and holding the SHIFT key until AyaNova completes loading.
If the error occurs, exit out of AyaNova and do the same steps again.
Now exit out of AyaNova, run AyaNova and log in - does the error still happen?

  • Joyce