Printing Issues within Ayanova

I have contacted support several times with an issue that they give me the standard response to - A response that I have repeatedly said does not work but … Still no help. If I use ayanova to print a work order, no problem - It prints fine. If I go to print a secons work order - Crash, the program aborts and I have to reload it.

In my own troubleshooting, If Ayonova is installed on it’s own, it works. If Simply Accounting and Crystal Reports (Which I use) is installed, for some reson Ayanova crashes on ever second print. My work around right now - Print a work order, exit Ayanova, reopen to print the next one, exit etc.

Yes, I have read and done ever single step on the printer troubleshooting section but as I have mentioned (MANY times to supprt) it does not work. I am not getting anywhere with support and we are expanding the business and need more licenses in the near future but before we can use Ayanova as a fully fledged dispatch system, we need this issue resolved.

If any user out there has seen this issue and knows of a solution, please let me know.

Thank you.

I should add an addendum to this - Printing to PDF does not work as I get random characters in the resulting pdf file?

Hi PGPhantom I apologize for your frustration with our tech support. I can’t recall any issue that ever went unresolved in all the years we’ve been doing this. I’d be happy to help you in more detail if you can provide your company name so I can take a look at the support emails between us in the past to get a handle on what’s been tried etc. Crystal reports does have some issues but as far as I know we’ve found the solution to all of them over the years so anything that is not resolved by the standard troubleshooting steps it must be a new issue we have never seen before.

If you can either post your company name or send a private email to me with it I’ll be able to help you with this issue.

  • John

Hello, just to follow up, when you had said you received no help from support I was astounded as the feedback we receive is very good and we have always put a very high level of importance on the quality of the support we provide. We did a search through our support email to try to determine how this could have happened and came across what we think is your issue.

I was waiting for you to confirm which company is yours, however there are no other clients with similar problem that have contacted us that have not confirmed the problem is solved and the issue we see leads me to think that there may be some sort of issue with you receiving email from us as our last two requests for more information went unanswered, so just in case this is your issue I have pasted our replies below in case you are not receiving our replies via regular email as it appears you might not be.

We received three requests about a similar issue from a client in Canada, one in November, one in March and one in May. In each case we replied within a few minutes and in the last two replies restated (as it also says on our web page with the troubleshooting steps of the specific issue you are having) that we need the specific information outlined in the troubleshooting page of the site in cases where the basic steps do not resolve the problem.

I’m assuming you did not receive those replies or you could have had this issue resolved a long time ago if you had provided the requested info. For the record here is a copy of the text from the troubleshooting page for your issue where it outlines the information we require. (for the record this is the exact info we require because we have seen this issue before and resolved it before, none of this information is not required):

If you continue to experience an issue, please ensure to provide the following information when contacting support:

Confirmation above has been performed with what steps

Detailed Info from AyaNova on this exact same computer where the error occurs - select menu Help -> select About this program -> click on Detailed Info -> copy to NotePad document, save and attach

Model and make of printer occurring with

Printer driver and version of the printer that is set as the default printer in Printer Settings on this computer

Does this occur if utilize a different printer and different default printer driver? (be sure to reboot the computer before testing if changed such settings)

Is printer local (physically attached to the computer) or via network access?

Confirmation if this occurs with all reports or if occurs with only certain reports, what report or reports from which screen or screens.

And here are our last two replies via email:

Date: Sat, 19 Mar 2005 16:47:37 -0800
To: xxxxxxxxxxx
From: AyaNova Sales & Technical Support <>
Subject: Re: Still having printing problems


Please refer to the AyaNova Technicial Answers web page for solutions to this issue.

If you have followed the recommended solution, please provide the information requested along with the listed solution if still experiencing issues. The AyaNova Technicial Answers web page is [b][/b] The section to review is Errors & Issues Printing From AyaNova, and is the second solution listed.

- Joyce

At 3/19/2005 04:30 PM, you wrote:

[b]At random times, Ayanova 1

Good IP Matching - Yes, that is me. As stated, I have uninstalled all printers etc. I even ourchased a new computer and started having the same issue on it as soon as Simply and crystal reports was installed. I am 100% certain that it is not a printer driver issue as I have removed all printers, set up a standard text printer and the same issue occurs. I installed Adobe Reader v7 and the PDF export did not work, I then installed the full Adobe writer and now the PDF works but … Here again, If I print twice - Exact same issue.

Event Type:Information
Event Source:Application Popup
Event Category:None
Event ID:26
Time:9:36:29 AM
Application popup: sc.exe - Application Error : The instruction at “0x3c2ce642” referenced memory at “0x00cad181”. The memory could not be “read”.

Click on OK to terminate the program
Click on CANCEL to debug the program

AyaNova CE support data compiled: Sep.17.2005 09:39:41

Current user:
Program path: C:\Program Files\AyaNova\sc.exe
DB Path: C:\PCCare\WorkOrders
DB Version: 171
Program version: AyaNova Classic Edition

Short date format: [M/d/yyyy]
Currency symbol: [$]
Language: [English]
Country: [United States]

Computer name: [OFFICE]
Operating system: [Windows XP Professional Version: Service Pack 2]

Drive information:
A:\ - Removable drive
C:\ - Fixed drive
D:\ - CDROM drive
E:\ - Removable drive
F:\ - Removable drive
G:\ - Removable drive
H:\ - Removable drive
Z:\ - remote network drive

RAM: 2096356 kb of physical memory
RAM: 33 percent of memory is in use

ADO Version : 2.8
DBMS Name : MS Jet
DBMS Version : 04.00.0000
OLE DB Version : 02.10
Provider Name : MSJETOLEDB40.DLL
Provider Version : 04.00.8227

LOGO FILE INFORMATION (c:\Program Files\AyaNova\logo.bmp)
File details:logo.bmp C:Sep.18.2001 16:20:00W:Sep.18.2001 16:20:0012 KB crc: 982881d3
Is it sample?:logo is SAMPLE (“your logo here”)
BMP opens with: C:\WINDOWS\system32\shimgvw.dll (Microsoft Picture Viewer - tested ok)

Files in program folder:
<Files in: C:\Program Files\AyaNova>
atl71.dll C:Mar.18.2003 18:05:58W:Mar.18.2003 18:05:58104 KB crc: 6de48669
ctschedule.ocx C:Oct.21.1999 11:21:36W:Oct.21.1999 11:21:36228 KB crc: 1938c885
license.txt C:Oct.23.2002 13:12:16W:Oct.23.2002 13:12:169 KB crc: 9ec50a28
logo.bmp C:Sep.18.2001 16:20:00W:Sep.18.2001 16:20:0012 KB crc: 982881d3
mfc71.dll C:Mar.18.2003 20:20:00

More to thisissue - I did some further testing and it is my modified report that is causing the issue. If I use the default reports from Ayanova - Appears to be no issue. I have modified the dispatch work order to suit my needs and it is that report causing the issue. from my understanding - Ayanova is designed so that reports can be customized so why would a customized report cause the program to crash on every second print?

Many many AyaNova users utilize custom reports.

If experiencing an issue with a specific report, it may be something particular to that customized report - either the query used, formatting, perhaps an embedded logo etc.

So as identifed in the list of information to provide us if experiencing such an issue, sending us a copy of your customized report file would have allowed us to help you determine what the issue is some months ago

Or it isrecommended you could customize a new copy of the original report file, testing each aspect that you change until you determine what exact customization causes the issue.

Do send us the following and we will have a developer take a look for you:

  1. Zip up your AyaNova database file SCDATA.Sc using WinZip
  2. Zip up a copy of the customized report file
  3. Include the manager password
  4. Send direct to

I have just email the requested information to support.

Was able to reproduce with the customized wodispst.rpt file that was provided that was requested to be sent in the original requests for information. Do always send requested information when we ask for it - it allows us to help you a lot faster.

I removed the embedded picture in the customized wodispst.rpt report that was provided, and retested printing multiple times with no issues.

This would indicate an issue with the embedded picture.

It would be recommended to create a new logo, remove the existing and embed the new. If it again results in errors printing, than again it is due to the embedded picture in the customized report. Utilize a different program to create the picture.

Looks like the logo is the problem. I have removed it and printing works. No matter what format I use, or the original source of the logo, If I insert it in Crystal designer, the program crashes. However, doing a bot of troubleshooting - If I add the log through the Insert Graphic command - CRASH. If I copy and paste the logo, it appears to work fine?

If I cut the existing graphic from your customized wodispst.rpt, and paste it intoMS Paint, save it as a bmp file, and than select menu Insert -> Picture in Crystal Reports with this report open, and insert the bmp file that I just made, it works fine printing the report multiple times.

Perhaps the program you are using to save the graphic in, or perhaps the attributes you have set for the graphic arecausing some conflictwith Crystal Reports.

But as the cut and paste works, just use that.

Thank you for sending the requested information which allowed us to help you troubleshoot what was occurring with your customized report.

We are now having a similar issue, I am going to try your fix and see what happens…

Looks like it worked if I used a 256 color logo image rather than a 24bit one… I should have just used grayscale fromt he get go, as they are only printed using black in… lol, live and learn eh? :w00t: