Problem with a part on a Workorder

We are having a strange problem with one of our workorders. It currently has a part assigned to it that shouldn’t be there. The line entry under parts for that item is grey and we cannot make changes but we can delete the part. However, when we try to save the workorder after deleting the part entry we get the following error:

There is already an open DataReader associated with this Command which must be closed first.

To get around this we tried to just mark the service as completed and close the ticket. Before we can it asks us to set all part to used. When we do that we get this error:

Error: User is not authorized to change a Workorder item part or the object or field being changed currently is read only.

We have tried this with an administrator account to see if it is a permission problem but still no luck.

Any suggestions? Thanks.


Hi Glenn

I haven’t come across that before. What would be best if I can get a copy of your AyaNova database and look into it here.

If you are using network Firebird, make a snapshot of the AyaNova database, and than zip up the snapshot file. If you are using SQL or SQL Express, make a backup of the database, and zip up the backup file. Do let me know what configuration you are using, and if SQL, what version of SQL (SQL Express, SQL Server 2000, etc).

Users do not need to stay out of AyaNova as I will only be checking a copy here. Than we can correspond as to the actual issue and detemine a solution that you can perform with your database there.

Please send via direct mail to
-a backup of your database file zipped using WinZip
-the AyaNova Administrator username and password
-and the workorder number
-also identify the part record in the Parts subscreen in the workorder so I am defintiely dealing with the exact item.

  • Joyce

Hi Glenn

I had not heard from you yesterday. If you have resolved the issue, do post it here for the benefit of AyaNova users.

  • Joyce