RESOLVED IN Setting Default Language via Global Settings does not set new user

[FORUM NOTE: This issue has been addressed in AyaNova]

To recreate:

Select a specific locale in the Default Language field in Global Settings (something other than English which is the default) and Save the Global Settings
Exit out of AyaNova and log back in
Now create a new user
The Default Language for the new user is still English even though you have set a new Default Language in Global Settings.
At this time, when creating a new user, do check that the Default Language for the new user is what you want it to be.