SOLUTION ImportexportCSV error "Index was out of range. Must be non-negative...

To recreate the issue:

Create a CSV file that is for importing Units that has 10 fields identified for at least the first row record
Open this CSV file via the importexportCSV for units and import into AyaNova
This has now “set” the importexport utility which will now “remember” importing using those columns and number of columns
Now create a new CSV file that has only 3 fields identified in the first row record.
Attempt to import this new csv file
Will get Error message :

Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index

This is because of the feature that the importexport utility “remembers” the columns read and imported from previously to save the user time, if you now import a file that has less columns, will get this error message.

Development will resolve this in a future update.

At this time, edit your CSV file so that it has the same number of columns as previous imported files.

UPDATE Apply the latest AyaNova 7 maintenance update to resolve.