Unable to run Ayanova client

Receiving errors on a machine that previously ran Ayanova with no problems. Running XP Pro SP2

I’ve tried everything on the support page with no success. The error I’m receiving is:

Ayanova could not open the database file:


The database driver gave the following reason:

Provider cannot be found. It may not be properly installed.

The same thing happens when I try to open a local copy of the database. However I can open scdata.sc directly using Access 2003.

I’ve tried to update MDAC from the Microsoft support page but the update program tells me I’m running a later version and quits. I’ve downloaded an MDAC checker program from Microsoft and it tells me that I’m running MDAC 2.8 SP1 with no problems.

What seems odd is that when looking at the properties of MSJETOLEDB40.DLL, there is no version tab. Also that file was not included in the update file even though it was listed as being there in the KB article.

Any suggestions?

Please zip up the AyaNova database file SCDATA.SC using WinZip and send it directly tosupport@ayanova.com

Include the manager username and password.

In this way we can confirm for you it is not something internally in the database causing this before we perform additional troubleshooting on the system itself.

Problem solved. Ran sfc (system file checker).

More info on sfc here: http://www.updatexp.com/scannow-sfc.html