WBI Error on a new install

I have just finished going through the documentation on setting up WBI on my computer - Followed all steps precicely including making the port 6969, Making sure asp is at the right version etc. Copied config.txt file to the bin directory but I get the following message when attaching locally to the WBI interface:

Server Error in ‘/AyaNova’ Application.

Failed to access IIS metabase.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.Hosting.HostingEnvironmentException: Failed to access IIS metabase.

The process account used to run ASP.NET must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For information on modifying metabase permissions, please see http://support.microsoft.com/?kbid=267904.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[HostingEnvironmentException: Failed to access IIS metabase.] System.Web.Configuration.MetabaseServerConfig.MapPathCaching(String siteID, VirtualPath path) +3591442 System.Web.Configuration.MetabaseServerConfig.System.Web.Configuration.IConfigMapPath2.MapPath(String siteID, VirtualPath vpath) +9 System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath, Boolean permitNull) +169 System.Web.CachedPathData.GetConfigPathData(String configPath) +389 System.Web.CachedPathData.GetConfigPathData(String configPath) +243 System.Web.CachedPathData.GetApplicationPathData() +68 System.Web.CachedPathData.GetVirtualPathData(VirtualPath virtualPath, Boolean permitPathsOutsideApp) +3536567 System.Web.Configuration.RuntimeConfig.GetLKGRuntimeConfig(VirtualPath path) +189

Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

I have rebooted, rerun the setup, removed the inteface, readded etc but get the same result every time. My only fear is this … I have IIS installed on an XP-Pro computer - Does the WBI interface allow for XP-Pro or not? IIS works fine. If it does, can you offer any suggestions as to why I am getting this error? I have followed the prior posts for troubleshooting but to no effect.

Hi again

Yes, WBI is compatible with IIS 5.1 that is on XP Pro.

I did a search on the internet for this error which is a Microsoft issue not an AyaNova issue and found the Microsoft support topic http://support.microsoft.com/?kbid=267904 this error message is because the IIS permissions to the metabase are insufficient, or because the IIS permissions are set incorrectly. Try that and post back what you find.

  • Joyce

The thing that you are missing is that I have already done all those steps. Including using aspnet_regiis -ga IUSR_Account as per the article but it still does not work - Same error. I have searched your forums for the same error and there was only the one instance. On a server this all worked fine but on a workstation running XP-Pro it is not? It is a new install so I am not sure where else to look.

Again for clarrification (Seeing as your response is always to read previous posts) - I have read all the posts on this topic and it is not working. What account needs to access the metabase for Ayanova?

For anyone else ever running into this particular error: I found the solution, Run aspnet_regiis.exe -i

The command is run from the command prompt in the ASP directory so search for aspnet_regiis.exe and use the version that you are using for IIS i.e. V2 or higher.

Thank you for posting what resolved your issue with your IIS - that running the IIS .NET repair fixed the issue.

  • Joyce